iRig Stomp I/O Preset Switching Latency

AXE I/O, iRig Stomp I/O, StealthPlug, StealthPedal, StompIO Guitar and Bass Audio Interfaces/Controllers, iRig Keys I/O and the iRig Keys family of MIDI controllers

iRig Stomp I/O Preset Switching Latency

Postby sliznut » Wed Jan 02, 2019 10:54 pm

Anyone else running into this? I'm not sure what the deal is. When I use it in stomp mode it seems like the switches immediately activate their assigned effects with little to no latency...like you would expect with a pedal.

But when I use it in preset mode, I have a very noticeable lag when I switch presets. This would make preset mode completely unusable in a live setting. I'm not sure if there is some parameter or setting I can tweak somewhere to overcome this or if it's just how it is. This is the exact reason I never used all in one effects processors back in the day because they always had that weird lag.
sliznut
 
Posts: 8
Joined: Fri Jan 05, 2018 6:24 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby Ryan_IK » Wed Jan 02, 2019 11:58 pm

Hello,

Thanks for your post.

Make sure to reach out to support for some help optimizing your settings to your system. They should be able to make some suggestions. When opening a ticket, let them know more information on your current set up, like operating system version, or platform.

Once your ticket is opened, send me a PM with your Ticket #.

http://www.ikmultimedia.com/contact-support/
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
Ryan_IK
Senpai
 
Posts: 1196
Joined: Mon Mar 30, 2015 4:20 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby sliznut » Thu Jan 03, 2019 3:17 am

Thanks Ryan. I'll send you the ticket info.
sliznut
 
Posts: 8
Joined: Fri Jan 05, 2018 6:24 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby cc_devil » Fri Aug 09, 2019 5:29 pm

I have the same exact problem using amplitube ios, with stomp I/O and iPad 2 ios 10.3.3.
I though i will never face this kind of lag with stomp i/o. And i also have the same reason with sliznut, to avoid any all in one fx because of this lag problem.

Are there Any setting i need to play with to eliminate the lag/delay ?


I dont have such problem when using Irig Pro with the same iPad and fcb1010.
With fcb1010, the preset change is lag free/0 latency. Just like using an analog stompbox.

I also tried the stomp i/o on the newest amplitube ios with my iPhone xs max, and the lag still there.

So I think this is maybe related to stomp i/o setting or firmware.
cc_devil
 
Posts: 4
Joined: Mon Jul 01, 2019 4:34 am

Re: iRig Stomp I/O Preset Switching Latency

Postby sliznut » Fri Aug 09, 2019 5:51 pm

Honestly I figured out it was ME. I'm used to pedals switching when you press down. The iRig Stomp I/O actually switches when you let your foot OFF of the pedal switches. If you get used to this you can time it better. Press down and then let off right when you want to change.
sliznut
 
Posts: 8
Joined: Fri Jan 05, 2018 6:24 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby cc_devil » Fri Aug 09, 2019 9:46 pm

sliznut wrote:Honestly I figured out it was ME. I'm used to pedals switching when you press down. The iRig Stomp I/O actually switches when you let your foot OFF of the pedal switches. If you get used to this you can time it better. Press down and then let off right when you want to change.



I will try that. But, are u sure the pedal wont change to be another function ? For example if we press the number 2 for 1 sec, it will interpreted as the next bank.
cc_devil
 
Posts: 4
Joined: Mon Jul 01, 2019 4:34 am

Re: iRig Stomp I/O Preset Switching Latency

Postby sliznut » Fri Aug 09, 2019 9:49 pm

You have to press two switches at once to switch banks if I recall. I don't actually sit there holding the switch down. I just had to get my brain used to stepping down just before I want it to kick in.
sliznut
 
Posts: 8
Joined: Fri Jan 05, 2018 6:24 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby cc_devil » Fri Aug 09, 2019 10:52 pm

sliznut wrote:You have to press two switches at once to switch banks if I recall. I don't actually sit there holding the switch down. I just had to get my brain used to stepping down just before I want it to kick in.


I just tried the release to change style switch with stomp io, and yup, it will immediately change after the switch release. But, as i said before, sometimes if we hold the switch a little bit too long, another function will replace the action. For example, when we use the switch #2, and hold it for 2sec, it will change to “next bank” function rather than kick in the preset on #2.

Maybe if we can add more delay when holding the change bank function, this is gonna be better. Or, make all of the switch to change preset on the press button rather than on the release button style.
cc_devil
 
Posts: 4
Joined: Mon Jul 01, 2019 4:34 am

Re: iRig Stomp I/O Preset Switching Latency

Postby sliznut » Fri Aug 09, 2019 11:02 pm

I would agree that it should switch on the press down, not the release. That is far more intuitive for anyone coming from using a normal pedal board. There probably is a way to do that because I'm pretty sure there is a midi signal sent both for press and release.
sliznut
 
Posts: 8
Joined: Fri Jan 05, 2018 6:24 pm

Re: iRig Stomp I/O Preset Switching Latency

Postby cc_devil » Sat Aug 10, 2019 6:09 am

I think the preset switch is in momentary mode, and hopefully we can change it to toggle mode just like in stomp mode.
cc_devil
 
Posts: 4
Joined: Mon Jul 01, 2019 4:34 am

Re: iRig Stomp I/O Preset Switching Latency

Postby duffy1977 » Wed Nov 06, 2019 11:16 pm

Was this solved? I'm having this issue, among a few others with my irig stomp io. Have this thing nearly a year and every time I try to use it something new comes up and I waste hours. If it didn't cost so much it would be in the trash by now grrrr never again.
duffy1977
 
Posts: 2
Joined: Sun Oct 16, 2016 1:28 am

Re: iRig Stomp I/O Preset Switching Latency

Postby Peter_IK » Mon Nov 11, 2019 4:50 pm

You should not have noticeable latency, please see this post and seek direct assistance from IK Support for any technical issues (noting per the forum rules linked at the top of each page and which you agreed to when signing up for this forum that this is not a medium for direct technical support).
Ryan_IK wrote:Hello,

Thanks for your post.

Make sure to reach out to support for some help optimizing your settings to your system. They should be able to make some suggestions. When opening a ticket, let them know more information on your current set up, like operating system version, or platform.

Once your ticket is opened, send me a PM with your Ticket #.

http://www.ikmultimedia.com/contact-support/
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
User avatar
Peter_IK
Kingpin
 
Posts: 13755
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere


Return to Interfaces & Controllers