Playing Amplitube and YouTube through same headphones?

AmpliTube 5, AmpliTube Custom Shop, AmpliTube Joe Satriani, AmpliTube Brian May, MESA/Boogie®,Orange™, Fender™, Hendrix™, Metal, AmpliTube SVX, and more for Mac/PC

Re: Playing Amplitube and YouTube through same headphones?

Postby SnoBear » Fri Apr 26, 2019 1:21 pm

Click on the little speaker icon in the Windows tray that is next to the date/time.(Lower Right Corner) In the upper right corner there should be this character "^". Click that and you should get a list box of various playback devices. Voicemeter Aux Input works for me. YMMV

Brad Phillips
SnoBear
 
Posts: 7
Joined: Sun Aug 27, 2017 5:31 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby SnoBear » Fri Apr 26, 2019 2:19 pm

One more thing comes to mind in all of this. Often, a restart of Voicemeter and/or a Windows reboot is necessary for some of these changes to take effect.
Don't forget twirling the dead chicken over your head and hopping up and down on one foot.

I'm sure the phase of the moon is involved as well ...

Good luck.
SnoBear
 
Posts: 7
Joined: Sun Aug 27, 2017 5:31 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby fmattioli » Sun Apr 28, 2019 4:43 pm

Anyone figure this out for iOS?? iPhone or iPad?

Thanks
fmattioli
 
Posts: 2
Joined: Sun Mar 04, 2018 1:03 am

Re: Playing Amplitube and YouTube through same headphones?

Postby fmattioli » Sun Apr 28, 2019 9:24 pm

Wouldn’t you know it! :shock: Just figured out I had to change the Amplitube app settings to Background Audio to ON!

Cheers :D
fmattioli
 
Posts: 2
Joined: Sun Mar 04, 2018 1:03 am

Re: Playing Amplitube and YouTube through same headphones?

Postby sta29982 » Fri May 17, 2019 12:53 pm

Come IK. Put the WASAPI driver in. I am using it all the time with my other software with no problems at all.
sta29982
 
Posts: 6
Joined: Wed Sep 14, 2016 8:57 am

Re: Playing Amplitube and YouTube through same headphones?

Postby C_berg1980 » Fri May 17, 2019 1:00 pm

should I use WASAPI instead of ASIO to be able to play ampltube and youtube at same time? I have tried using voicemeeter and can not get it to work
C_berg1980
 
Posts: 16
Joined: Sat Jan 20, 2018 4:03 am
Location: Ohio

Re: Playing Amplitube and YouTube through same headphones?

Postby C_berg1980 » Fri May 17, 2019 1:00 pm

can i use wasapi in windows 10?
C_berg1980
 
Posts: 16
Joined: Sat Jan 20, 2018 4:03 am
Location: Ohio

Re: Playing Amplitube and YouTube through same headphones?

Postby sta29982 » Fri May 17, 2019 1:06 pm

IK Multimedia have not made WASAPI an option for Amplitube.
sta29982
 
Posts: 6
Joined: Wed Sep 14, 2016 8:57 am

Re: Playing Amplitube and YouTube through same headphones?

Postby C_berg1980 » Fri May 17, 2019 1:11 pm

Thaks sta29982 for the reply. I'm still trying to figure a way to use Amplitube and Youtube or other program at same time. I gave up on voicemeeter as i can not configure it to work correctly. It's very disappointing that Tech support can not even help me out on finding a way to make this work.
C_berg1980
 
Posts: 16
Joined: Sat Jan 20, 2018 4:03 am
Location: Ohio

Re: Playing Amplitube and YouTube through same headphones?

Postby Ryan_IK » Fri May 17, 2019 6:09 pm

Hey Guys,

We do have a suggested work around to help Windows users get past this system limitation. Please note, these steps use third party software and should be followed at your own risk. I've followed this up with an FAQ for future users, since this seems to be a common interest.

These steps will help you use AmpliTube with your favorite music and streaming services, like YouTube, Spotify, or Pandora.

  1. Download and install VB-Cable here. This program will allow you to route your system audio to a virtual cable.
  2. Download and install ASIO4ALL here. This driver set will allow multiple devices to be used at a single time on Windows.
  3. Restart your system to allow all the proper changes to be made to your system. This should be done with any driver installations.
  4. Next, open up your Control Panel and go to the Hardware & Sounds section -> Sounds. Set your systems output to the CABLE Input (VB-Audio Virtual Cable).

    Image
  5. Open the latest version of AmpliTube 4. If you do not yet have AmpliTube, download this from My Products.
  6. Go to the Audio/MIDI Set Up under Settings in AmpliTube 4 to select ASIO4ALL as your audio input and output device.

    Image
  7. Next, using the ASIO4ALL panel activate both your audio interface and VB Cable.

    Image
  8. Inside your Audio/MIDI Set Up window, select Left Input (Input 1) as your iRig or instrument input, then select "VB-Audio Point 1" as the Right Input (Input 2). Select your Output device as your systems output.

    Image
  9. Back inside AmpliTube 4 notice Channel 1 is set to Input 1 (Your iRig) by default. Set Channel 2 to Input 2 (Your VB-Audio Cable) press the "R" (Record enable) on both tracks are you are ready to go!

    Image

If you need additional help after reading this information, contact our support team here. After reaching out to support, send me your Ticket # so I can track your progress.
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
Ryan_IK
Senpai
 
Posts: 1451
Joined: Mon Mar 30, 2015 4:20 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby Ryan_IK » Fri May 17, 2019 6:11 pm

sta29982 wrote:IK Multimedia have not made WASAPI an option for Amplitube.

For future user reference, this is untrue, WASAPI or Windows Audio can be selected in Windows 10. This will be the option offered as "Windows Audio" inside of the Audio/MIDI Set Up in AmpliTube 4. This is separate from Direct Sound or ASIO options.

Moving forward, I do hope the work around above helps! :D
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
Ryan_IK
Senpai
 
Posts: 1451
Joined: Mon Mar 30, 2015 4:20 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby sta29982 » Sat May 18, 2019 3:43 pm

I see Window Audio as an option, it does not specify which one. I think Microsoft are up to the the third type of Audio that has been created with WASAPI being the latest. WASAPI has a shared mode on most software. On Amplitube there is no option to use WASAPI in shared mode, the only option is exclusive mode.
sta29982
 
Posts: 6
Joined: Wed Sep 14, 2016 8:57 am

Re: Playing Amplitube and YouTube through same headphones?

Postby SnoBear » Sat May 18, 2019 3:58 pm

Seems to me that the shared option was removed in version 4.6 of Amplitube 4.
SnoBear
 
Posts: 7
Joined: Sun Aug 27, 2017 5:31 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby oldbluejoe » Sun May 19, 2019 6:09 pm

Hi,

thanks for the workaround Ryan, it really works!

First I couldn't get it to work, but after some tweaking I found one important step that was not mentioned in your instructions. Maybe this is obvious to others or it works by default, but it got me struggling for a while.

So in your system sound properties you also have to go the recording tap and set your hardware soundsystem as default. In my PC it's the regular Realtek speakers. And then the virtual cable can listen to the correct input feed.

That's what got me there eventually, hope this is helpful to others as well..

oldblue
oldbluejoe
 
Posts: 24
Joined: Sat Apr 04, 2015 5:53 pm

Re: Playing Amplitube and YouTube through same headphones?

Postby C_berg1980 » Mon May 20, 2019 2:36 pm

I followed the directions to the T. I still can not get it to work. I only have AT4 sound no Youtube or secondary audio. I can not figure out what I am doing incorrectly
C_berg1980
 
Posts: 16
Joined: Sat Jan 20, 2018 4:03 am
Location: Ohio

PreviousNext

Return to AmpliTube Guitar Amp & FX modeling