iRig Pro DUO Power Issue

AXE I/O, iRig Stomp I/O, StealthPlug, StealthPedal, StompIO Guitar and Bass Audio Interfaces/Controllers, iRig Keys I/O and the iRig Keys family of MIDI controllers

iRig Pro DUO Power Issue

Postby Davew10 » Mon Jun 03, 2019 8:05 pm

Hi all,

I am having an issue with my iRig Pro DUO with power supply, which I have been having since I bought the unit some time ago.

When using batteries, the product works for about 10 minutes before giving a feedback noise and eventually not emitting any instrument sound. When trying to power using USB, both bottom lights flash blue continuously, and the unit cannot be found / will not give any input to my MacBook.

I have now just bought a 9v dc power supply, and this is giving the exact same issue as the USB power method, almost as if the unit does not even recognise that a power supply is present, and is trying to power using the USB cable, which does not seem sufficient.

Has anyone experienced any similar issues, or any ideas on potential causes / fixes?
Davew10
 
Posts: 1
Joined: Mon Jun 03, 2019 8:01 pm

Re: iRig Pro DUO Power Issue

Postby Peter_IK » Tue Jun 04, 2019 11:20 pm

Odd, since that flashing blue indicates phantom power is powering up as you can find in the manual:

Flashing Blue: phantom power is powering ON. To avoid audio bumps iRig Pro DUO is muted while phantom power is turning ON, so it is normal to not hear any signal until this LED turns steady BLUE when turning on +48V phantom power


I would recommend opening a ticket with IK Support who can perform deeper troubleshooting and who can surely get you up and running. They can be reached at http://www.ikmultimedia.com/contact-support

Thank you.
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
User avatar
Peter_IK
Kingpin
 
Posts: 13602
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere


Return to Interfaces & Controllers