iRig Pro I/O audio not working with iPad

AXE I/O, iRig Stomp I/O, StealthPlug, StealthPedal, StompIO Guitar and Bass Audio Interfaces/Controllers, iRig Keys I/O and the iRig Keys family of MIDI controllers

iRig Pro I/O audio not working with iPad

Postby tuzmusic » Mon May 07, 2018 11:12 pm

I have a MIDI keyboard plugged in to my iRig Pro I/O via MIDI, a mic plugged in, a headphone out going to my amp. My iPad Air 2 or iPhone 6 (I've tried both) is running iGrand Piano and Mic Room. When I play the keyboard, the MIDI light activates on the iRig device, and I see the keys play on the iGrand screen ? the MIDI is working.

However, no sound comes out of the iRig headphone jack. I have of course ensured it's turned up. No sound comes out from a number of sources: Spotify, iTunes, Mic Room. Mic Room doesn't seem to recognize that the iRig Pro is plugged in.

When I try plugging the iRig into my computer, it works fine. Sound comes out and everything. I've tried using the USB mini DIN cable to connect to the iPad through a camera kit, but then my iPad says the iRig requires too much power (at least it clearly recognizes its existence!).

And, I've used this iRig with the same iOS devices in the past and it's worked. This has rendered my unit essentially unusable.

Goodness gracious, please help!!!
tuzmusic
 
Posts: 6
Joined: Thu Dec 14, 2017 4:20 pm

Re: iRig Pro I/O audio not working with iPad

Postby Peter_IK » Mon May 07, 2018 11:32 pm

Have you also opened a ticket with IK Support? I'm sure they can offer deeper technical assistance to help you with the issue you are having (and this is a user-to-user forum so you may not receive help expediently for tech issues vs via official support channels). Thanks!
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
User avatar
Peter_IK
Kingpin
 
Posts: 15276
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: iRig Pro I/O audio not working with iPad

Postby vincent_n2003 » Tue May 08, 2018 6:17 am

You might try going to the input selection in the studio area and reselecting channel 1. I think it might be a bug in the software.
vincent_n2003
 
Posts: 9
Joined: Tue May 08, 2018 6:11 am

Re: iRig Pro I/O audio not working with iPad

Postby tuzmusic » Tue May 08, 2018 12:22 pm

What studio area? What software?
tuzmusic
 
Posts: 6
Joined: Thu Dec 14, 2017 4:20 pm

Re: iRig Pro I/O audio not working with iPad

Postby vincent_n2003 » Tue May 08, 2018 2:16 pm

It's where the 8 track recorder is. I believe it's at the top of the screen.
vincent_n2003
 
Posts: 9
Joined: Tue May 08, 2018 6:11 am

Re: iRig Pro I/O audio not working with iPad

Postby tuzmusic » Tue May 08, 2018 3:08 pm

I'm using the irig pro i/o interface, which to my knowledge has no software, with iGrand Piano and Mic Room apps. None of them have a recorder screen or input/output selection or anything.
tuzmusic
 
Posts: 6
Joined: Thu Dec 14, 2017 4:20 pm

Re: iRig Pro I/O audio not working with iPad

Postby vincent_n2003 » Tue May 08, 2018 3:24 pm

If you download Amplitube, do you get the same interface audio issue?
vincent_n2003
 
Posts: 9
Joined: Tue May 08, 2018 6:11 am

Re: iRig Pro I/O audio not working with iPad

Postby tuzmusic » Wed May 09, 2018 2:02 pm

So I've downloaded Amplitube CS onto my iPhone. When I play the demo through the iRig, I can see the blue light flashing, indicating some sound is coming in. Still no sound through the headphone output.

I've gone down to the recorder area (which looks very cool!) and I see the meters moving. I switch the record-enable between channels 1 and 2 and back again (as I believe you suggested), and I see the meter moving from one channel to another, but there's still no sound.

Any other ideas?
tuzmusic
 
Posts: 6
Joined: Thu Dec 14, 2017 4:20 pm

Re: iRig Pro I/O audio not working with iPad

Postby vincent_n2003 » Wed May 09, 2018 3:36 pm

Dependent on what iPhone (or iPad) you are using, can you get audio out of the audio jack of the iPhone/iPad?

You stated you used this device before and it worked, so what changed that made it act differently. Did you update software or the OS?
vincent_n2003
 
Posts: 9
Joined: Tue May 08, 2018 6:11 am

Re: iRig Pro I/O audio not working with iPad

Postby tuzmusic » Wed May 09, 2018 4:28 pm

Yes I can get sound out of the iOS device itself – both speaker and headphone jack. With the frequency of updates to iOS, yes I imagine I've updated since it last worked. I can't imagine anything that would be different, so I'm open to ideas.
tuzmusic
 
Posts: 6
Joined: Thu Dec 14, 2017 4:20 pm

Re: iRig Pro I/O audio not working with iPad

Postby vincent_n2003 » Thu May 10, 2018 8:49 pm

You could try another lightning to DIN cable. Maybe see if your local music store has a cable you could try out.

At this point, hopefully technical support from IK Multimedia can resolve this for you.
vincent_n2003
 
Posts: 9
Joined: Tue May 08, 2018 6:11 am

Re: iRig Pro I/O audio not working with iPad

Postby Powerfibers » Fri Sep 18, 2020 2:32 am

Can I just add that the batteries do matter. I was under the impression that they were only for the phantom power. If your AAs die, the rig will not work.
Powerfibers
 
Posts: 1
Joined: Sun Apr 19, 2020 7:22 pm


Return to Interfaces & Controllers