iRig Stream issue on iOS 15

AXE I/O, AXE I/O Solo, iRig Stomp I/O, Guitar and Bass Audio Interfaces/Controllers, iRig Keys I/O and the iRig Keys family of MIDI controllers

Re: iRig Stream issue on iOS 15

Postby tylerjalford » Thu Jul 21, 2022 2:35 am

I'm having the same issue with the iRog Stream Pro, won't engage in recording when connected to power supply. It only works periodically. It's something software/driver related with iOS and IK.
tylerjalford
 
Posts: 1
Joined: Sat Mar 16, 2019 11:16 am

Re: iRig Stream issue on iOS 15

Postby djniwrehs08 » Mon Aug 01, 2022 4:52 am

I've been having the same problem on iPhone iOS15.6 But it works perfectly on my iPad 7th Gen as long as you keep the iRig Recorder open and Background Audio settings ON.

Using on laptop also works fine.

This seems to be a firmware issue of iRig Stream on iPhone only.

Appreciate your help to resolve this issue since the device is not that cheap.
djniwrehs08
 
Posts: 1
Joined: Mon Aug 01, 2022 4:50 am

Re: iRig Stream issue on iOS 15

Postby Peter_IK » Mon Aug 01, 2022 4:10 pm

That is not the normal behavior, please open a ticket with IK Support for direct and official assistance and I'm sure they will get you up and running.
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
From the rules: Moderator decisions are not a matter for forum discussion and are final.
User avatar
Peter_IK
Kingpin
 
Posts: 18238
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: iRig Stream issue on iOS 15

Postby Billevans8 » Mon Aug 01, 2022 4:18 pm

I opened a ticket almost a year ago about this issue, still unresolved and support has stopped replying. Any advice on what to do
Billevans8
 
Posts: 11
Joined: Sun Sep 26, 2021 4:08 pm

Re: iRig Stream issue on iOS 15

Postby Peter_IK » Mon Aug 01, 2022 6:39 pm

Have you replied to your support ticket and they haven't replied to you? If so, please provide your ticket number
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
From the rules: Moderator decisions are not a matter for forum discussion and are final.
User avatar
Peter_IK
Kingpin
 
Posts: 18238
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: iRig Stream issue on iOS 15

Postby Billevans8 » Tue Aug 02, 2022 4:23 am

Yes followed up twice since May. Ticket was open in October 2021.
#9682505

thank you Peter
Billevans8
 
Posts: 11
Joined: Sun Sep 26, 2021 4:08 pm

Re: iRig Stream issue on iOS 15

Postby djquartz306 » Fri Aug 05, 2022 10:17 pm

Yes this is definitely an issue, I was on Android first but the audio quality was not great.

I was able to upgrade to an iPhone 13 strictly for streaming purposes.

Using it with a hub that has USB, Ethernet and Lightning port for charging.

Nothing but issues since. It will power, not power, pass audio, not pass audio, working normally and then disconnect, etc, etc.

Tried different versions of ios 15, same deal.

Testing ios 16 right now because I was hoping this was an OS issue, same problems.

I've already contacted support because I checked for a firmware update and none were available.

If I connect iRig directly to the phone it is detected.

It doesn't make any sense whatsoever, the hub is working.

I did a continuous ping test to the iphone and the connection is stable.

I've seen different behaviours...

When the iRig is connected the ping latency is low, then I will open TikTok and the ping times start fluctuating badly.

Disconnect everything, reconnect and then the connection is stable again.

I was just testing again and the iRig was powered but not passing any audio. I was testing with the recorder app and nothing.

There is also another weird behaviour I noticed.

Power down the phone and connect everything. Power up the phone, iRig is powered everything appears active. Then once the phone hits the desktop the iRig flash and disconnects.

or

Everything is normal and you open TikTok and the iRig flashes and shuts off. Do the same with the recorder, flashes and shuts off.

Then maybe one out of 20 times it will actually work right.

There is definitely an issue between the iRig and iPhone from my investigation.

It appears to either be a firmware level, OS or chipset issue.

This is an iRig issue. I tested with a usb headset that is rgb lighted with my hub and it works no problem.

I've plugged it into a PC and MAC, the unit is powered and detected without issue.

This is specifically an iPhone issue from what I have tested and checked thus far.
djquartz306
 
Posts: 4
Joined: Fri Aug 05, 2022 10:09 pm

Re: iRig Stream issue on iOS 15

Postby djquartz306 » Sat Aug 06, 2022 2:22 am

I was just doing some more testing and I had reboot my phone about two times.

Then unplug/reconnect the hub about three times.

The blue indicator finally came on. So I went into the recorder app and the green indicator is on and the vu's are registering sound in the app.

So unless the iRig cannot work through a hub, this doesn't make sense.

Everything else works on it.

I connected the iRig to my android phone with usb a - usb c connector and it powered up.
djquartz306
 
Posts: 4
Joined: Fri Aug 05, 2022 10:09 pm

Re: iRig Stream issue on iOS 15

Postby djquartz306 » Sun Aug 07, 2022 4:25 am

Ok did some further testing and I had an idea.

I figured this must be power related. So I found an inexpensive powered hub.

https://www.bestbuy.ca/en-ca/product/be ... y/15529946

I noticed when I rebooted my phone and connected everything.

Lightning Hub -> USB Hub -> iRig Stream

The faint blue light became bright and I tested the recorder app and there was sound coming in no problem.

So a powered hub definitely helps when connecting it to a phone. It needs more power than the phone port can provide through a lightning adapter.

Another issue I found is when the iRig engages, it starts causing latency in the ethernet connection.

If I disconnect and reconnect the iRig from the powered hub, this goes away.

It almost seems like an OS issue. I noticed it happened with the recorder app also.

I disconnected the iRig and reconnected it to the powered hub, the latency went away and the audio still worked.

I would recommend support test an iPhone with a hub and ethernet connected to track down this issue.
djquartz306
 
Posts: 4
Joined: Fri Aug 05, 2022 10:09 pm

Re: iRig Stream issue on iOS 15

Postby Billevans8 » Sun Aug 07, 2022 5:02 am

Thanks for the testing effort! I’ll try this soon
Billevans8
 
Posts: 11
Joined: Sun Sep 26, 2021 4:08 pm

Re: iRig Stream issue on iOS 15

Postby djquartz306 » Mon Aug 08, 2022 4:10 am

Did a TikTok test today and it seems everything is working much better.

A fellow DJ popped into my channel and confirmed the sound and video was good.

I'm going to keep testing with this setup for now.

What I want to try next is the apple usb 3 camera kit with the powered hub and the apple
ethernet adapter.

I would like to see if the latency glitch goes away.
djquartz306
 
Posts: 4
Joined: Fri Aug 05, 2022 10:09 pm

Previous

Return to Interfaces & Controllers