LAtency problem!

AmpliTube 4, AmpliTube Custom Shop, MESA/Boogie®,Orange™, Fender™, Hendrix™, Metal, Ampeg® SVX, Preset XChange, more for Mac/PC

LAtency problem!

Postby Keven.stpierre » Fri Apr 21, 2017 4:47 pm

Hi , so i downloaded AmpliTube 4 for pc . When i try to use it the sound sound like **** and is delayed alot . Im currently using an scarlett 2i2 2nd generation as a sound card so there should be no problem at all . I tried with my xlr mic and and my 1/4 plug with my electric guitar and i dont know what to do . i used that setup in alot of amp program and the sound is amazing with no delay but with AmpliTube it sound like **** and its getting me mad haha! Any tips on how to solve this problem ?
Keven.stpierre
 
Posts: 1
Joined: Sun Dec 25, 2016 7:16 am

Re: LAtency problem!

Postby garfy » Fri Apr 21, 2017 5:10 pm

Hello Keven.stpierre

Have you gone through the basic setup of the software? I assume you are using it in standalone mode, so make sure you:

1) Go into Audio MIDI setup in AmpliTube
2) Ensure that your 2i2 is selected as the input and output device
3) Reduce the Buffer Size until the latency is gone. If you go past the point that you start to get glitchy sounds then you need to settle on a buffer size that your PC is happy with.

Hope that cures the issue.
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.13.6
Logic 10.4.6 Reason 8.3
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
garfy
Moderator
 
Posts: 852
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK

Re: LAtency problem!

Postby andrew060 » Wed Jul 19, 2017 6:45 am

Hi Garfy,

I have a similar problem but when I try to reduce the buffer my lowest option is 256!

Are there any other settings I should be looking at?

I have pro tools on my pc and that doesn't suffer the same problem

Cheers,

Andy
andrew060
 
Posts: 1
Joined: Tue Jul 18, 2017 2:28 pm

Re: LAtency problem!

Postby garfy » Wed Jul 19, 2017 3:26 pm

Hey Andrew060

andrew060 wrote:Hi Garfy,

I have a similar problem but when I try to reduce the buffer my lowest option is 256!


Do you mean it won’t let you choose any lower than 256 or it glitches if you go lower than that?

What interface are you using?
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.13.6
Logic 10.4.6 Reason 8.3
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
garfy
Moderator
 
Posts: 852
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK

Re: LAtency problem!

Postby DCSmith » Sat Apr 06, 2019 11:09 pm

I just downloaded and installed AmpliTube Free (latest version) I am running a Scarlett 6i6 (2nd generation) on Windows 10 Pro. With the default buffer size of 2048, nice sound, but horrendous latency. I reduce the buffer size and I get the glitchy sounds, but still some latency. Frustrated, I uninstalled the lot.

Playing guitar direct thru the Scarlett 6i6 - no latency at all.

Disappointed.
DCSmith
 
Posts: 3
Joined: Sat Apr 06, 2019 10:33 pm

Re: LAtency problem!

Postby Peter_IK » Sun Apr 07, 2019 2:02 am

DCSmith wrote:I just downloaded and installed AmpliTube Free (latest version) I am running a Scarlett 6i6 (2nd generation) on Windows 10 Pro. With the default buffer size of 2048, nice sound, but horrendous latency. I reduce the buffer size and I get the glitchy sounds, but still some latency. Frustrated, I uninstalled the lot.

Playing guitar direct thru the Scarlett 6i6 - no latency at all.

Disappointed.

You should be able to get far better results and use far lower buffer settings with that interface. I would make sure you are using your latest ASIO drivers from Focusrite for the interface. Also, the direct sound may be from a direct monitoring setting so there would be little to no latency there.

Also, our IK Support staff would be happy to assist you at http://www.ikmultimedia.com/contact-support and I'm sure they can get you up and running.

Thanks!
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
User avatar
Peter_IK
Kingpin
 
Posts: 13845
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: LAtency problem!

Postby DCSmith » Sun Apr 07, 2019 10:03 pm

I downloaded & installed ASIO4ALL and that seemed to help immensely. However, This product is way overkill for my needs. All I was looming for was a few effects (chorus, reverb, etc.) I found none that were free.

I went back to my Digitech RP360 XP pedal.
DCSmith
 
Posts: 3
Joined: Sat Apr 06, 2019 10:33 pm

Re: LAtency problem!

Postby garfy » Mon Apr 08, 2019 9:10 am

Glad that ASIO4ALL cured your problems.

DCSmith wrote:All I was looming for was a few effects (chorus, reverb, etc.) I found none that were free


In the free AmpliTube CS version, there are effects included for no extra cost. These are found in the Stomp section and are Chorus, Flanger, Opto Tremolo, Delay, Wah Pedal, Diode Overdrive, Compressor, Graphic EQ and Volume Pedal.

The reverb can be found built into each of the amps and then there is additional 'ambient' reverb sound that can be added using the room mics in the mixer section.

Hope that helps.
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.13.6
Logic 10.4.6 Reason 8.3
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
garfy
Moderator
 
Posts: 852
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK

Re: LAtency problem!

Postby DCSmith » Sat Apr 13, 2019 7:03 pm

Thanks for the information. I'll play around with it.
DCSmith
 
Posts: 3
Joined: Sat Apr 06, 2019 10:33 pm

Re: LAtency problem!

Postby garfy » Sun Apr 14, 2019 10:36 am

Great stuff, have fun and even better as it's free :D



As this post is resolved for the user it will be marked as such and locked to keep the forum tidy. If you are reading this thread because you are having similar issues or have questions of a related nature, please feel free to start a new topic.
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.13.6
Logic 10.4.6 Reason 8.3
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
garfy
Moderator
 
Posts: 852
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK


Return to AmpliTube Guitar Amp & FX modeling