Cannot export to SampleTank 4 - solved

The SampleTank Editor is provided without direct support. However this IK user forum is available for users to share questions and solutions.

Cannot export to SampleTank 4 - solved

Postby Jongtr99 » Thu May 05, 2022 4:55 pm

FINAL EDIT! as my earlier edits below suggest, it all works if I run the program as Administrator to start with!

But I'm leaving this post here in case anyone else gets the same issue.

I have SampleTank 4 registered, and have used the Editor for the first time to create an instrument. All went went well until I tried Export Instrument to SampleTalk. Hilariously (and highly irritatingly), the youtube tutorial says "this is the easy part"!! Er, nope...

What happens is a window appears saying "Saving instrument", and it just hangs at 0%. The Cancel button doesn't work, and Editor has to be closed.

When I open Editor again I get the message "10 days grace period has expired". When I click OK for the Authorization Manager, I can enter the serial for SampleTank 4, which says OK.

But this makes no difference. The Editor is still (apparently) not authorized and I have no separate serial number for it. Clicking Cancel just takes me round the same loop (Load my saved instrument, Export to SampleTank ... saving 0% forever....)

I've tried uninstalling and re-installing, no luck.

So it's impossible to actually export the instrument to actually use it. Unless anyone knows any workaround? Is there something I'm missing here?

EDIT: just discovered a couple of other things which might clarify the problem:

1. When I open the existing instrument and click Save Instrument, there's an error message: "Instrument ST4 error. Cannot open file at path C:\Program Files\IK Multimedia\SampleTank Editor\Instruments" (that's where the file is). Clicking "Save Instrument as" directs me elsewhere (to my own User folder). That was where I had to save the file to begin with - I got a message saying I didn't have permission to save it in the correct folder, and to contact my Administrator! So I saved it where it told me, and copied it across later (then I just got the administrator warning to continue).

2. If I click "Export Instrument to SampleTank" and check the two boxes to "Remove skipped Round Robins and unassigned Waveforms" (either one or both), then the saving process quickly to 50% ... and hangs there instead.
Posts: 2
Joined: Sun Apr 17, 2022 3:15 pm

Re: Cannot export to SampleTank 4 - solved - NOT

Postby Jongtr99 » Thu May 05, 2022 6:02 pm

[Sigh] Now there is another problem. The above process didn't actually work after all.

Firstly, I found my midi keyboard no longer worked with the Editor. The sounds were all there from the onscreen keyboard, but I was unable to assign my keyboard as a midi device. It's listed there under Active MIDI Inputs, but I can't check the box (as I could when I first created my instrument).

Secondly, when I open SampleTank 4, I find my instrument listed there, but it doesn't work. The error message is: "Instrument ST4 Error. Cannot locate Tank at path 'C:/Users/Public/Documents/IK Multimedia/SampleTank 4/Imported Samples/Samples.pak'."
Posts: 2
Joined: Sun Apr 17, 2022 3:15 pm

Return to SampleTank 4 Editor