Logic Pro X T-RackS plugins not showing up at all.

Discussion about MixBox and T-RackS

Logic Pro X T-RackS plugins not showing up at all.

Postby Goldman1 » Sun Dec 19, 2021 3:17 am

hey guys, I’ve just purchased the Classic T-RackS Clipper after hearing great reviews about it online: but I’m having a really frustrating time as none of the T-RackS 5 plugins will show up in Logic Pro X at all.

I’m running Mac OS Sierra 10.12.6 and my Logic Pro X is vers 10.2.4

They aren't showing up alongside my other plugins when I open a new VST slot on a channel send. They show up in the Plugin Manger under IK Multimedia, so I select all of them and try rescanning all the IK Multimedia plugins from the plugin manager only to be told they “can’t be opened”. The code reads as follows from the AU Validation tool (this is just an example for one of the plugins but it reads like this for all of them)

"validating Audio Unit TR5 Suite by IK Multimedia:

AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options

VALIDATING AUDIO UNIT: 'aufx' - 'TRS5' - 'Ikmm'
Manufacturer String: IK Multimedia
AudioUnit Name: TR5 Suite
Component Version: 5.5.0 (0x50500)

* * PASS
FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF "

I’ve tried everything, from deleting my Logic Preferences file to deleting the plugin cache file so Logic rescans all plugins. When I do this I get this message:

" While verifying Audio Unit compatibility, Logic Pro X encountered 70 Audio Unit plug-in(s) which did not pass the Apple AU validation. These plug-ins have been excluded from further usage in Logic Pro X to prevent possible problems or crashes."

I’ve uninstalled and reinstalled the T-Racks app and all related files multiple times and even tried installing an older version (5.5) but nothing is working.

I really need to get this Clipper up and running in my DAW as I have a master I got to finish today and bought it especially for that! Pls let me know what I can do to solve this problem bc its driving me nuts, thx :|
Posts: 1
Joined: Wed Dec 15, 2021 11:40 pm

Re: Logic Pro X T-RackS plugins not showing up at all.

Postby garfy » Mon Dec 27, 2021 4:37 pm

Hello Goldman1 and welcome to the forums.

As this is a user-to-user forum and not direct to IKM support, in case no one else chimes in here with advice or a solution the best thing to do is check the FAQs, via https://www.ikmultimedia.com/contact-su ... ck=QUICKSW

If these do not resolve the issue, there is a link to the Technical Support form at the top of the Search FAQs page, for direct help from Official IK Support. They endeavour to reply within 2 working days, but obviously considering the current situation things may take longer than usual.

And, to help others who run into a similar problem, please let us know what you did to resolve the issues, but without directly quoting any correspondence from official support.
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.15.7 Logic 10.6.1 Reason 11
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
Posts: 2133
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK

Return to Mixing & Mastering with T-RackS and MixBox