All Sorts of Problems with Miroslav Philharmonik 2

Hammond B-3X, Syntronik, Syntronik Deluxe, SampleTank, Miroslav Philharmonik 2, SampleTron 2, and all Powered by SampleTank instruments and sounds for Mac/PC

All Sorts of Problems with Miroslav Philharmonik 2

Postby diloretojazz » Mon Aug 03, 2020 4:31 pm

Hi everyone, I'm very new here and would love some help, as this is a very frustrating process for something that should be pretty straightforward.

For some upfront clarification: I use Windows 10, 64 bit. Only DAW I work with regularly is Ableton 10.

I just purchased my first IK product, Miroslav Philharmonik 2 CE, with the goal of being able to use it in Ableton 10 Live, just like I have done with various other VST3 plugins from other companies. Yet, despite downloading it into the exact same folder as all the other VST3 plugins, the program just will not run and I receive a DLL error every time, whether I open it on its own or in Ableton. I have downloaded and reinstalled several times to no avail.
In addition, I can't even get it to import into SampleTank4! every time I try to import the Miroslav 2 CE library into ST4, all it does is open a browser window back to my IK products ready for download. So Miroslav won't load in ST4, either.

Is there some easy step that I'm not getting? I was always told that as long as all VST3 plugins are kept in the same location, Ableton will always be able to find them. Please help if you can - from reading other forum posts, it seems like this problem has been persistent for awhile. Thank you!
Posts: 1
Joined: Mon Aug 03, 2020 4:01 pm

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby Peter_IK » Mon Aug 03, 2020 4:51 pm

I've had Miroslav Philharmonik 2 running in Windows 10 for years, without issues. Sometimes (by that I mean, most times) issues that appear exactly the same are not quite so. I don't use Ableton but yes as long as you installed Mirsolav Philharmonik 2 CE into the correct directory that Ableton Live is looking at it should run no problem. The default choice during the installation of the Miroslav Philharmonik 2 CE plugin would likely work best, though.

I would recommend uninstalling and reinstalling it using the default choices and making sure Ableton Live is also pointed to the directory that Miroslav Philharmonik installs to (you should see it during the installation process). Also, of course, make sure all of the sound libraries are unzipped and then their installers are run too. That should work. If not, the IK Support team would be happy to assist you directly to see what is happening in your case and they can be reached at

Thank you.
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
From the rules: Moderator decisions are not a matter for forum discussion and are final.
User avatar
Posts: 17330
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby garfy » Mon Aug 03, 2020 4:57 pm

Hi diloretojazz and welcome to the forums.

Unfortunately, I can't give much help on the first issue. If you have installed the software to its default location there shouldn't be an issue. Hopefully a Windows/Ableton user will be along shortly to help you out with that. If not then I would suggest opening a ticket with Official Support here:

They endeavour to reply within 2 working days, but obviously considering the current situation things may take longer than usual.

With regards to opening the sounds in ST4, you don't need to go through the import function as the files are already in the correct format. Under Settings>Sound Content in ST4 you need to add an additional pathway to where your SampleTank 3 folder is (as the MP2CE content is held within). Click Add and navigate to the SampleTank 3 folder and, once added, click Rescan All if it doesn't do this automatically. That should add your MP2CE sounds to the main ST4 menu.

Hope that helps.
System Specs: 2012 Mac Mini 2.6 i7 & 2015 MBP 2.2 i7, 16GB RAM
macOS10.14.6 Logic 10.5 Reason 11
Various IK, NI, Waves, Softube, Eventide, XLN software
Focusrite 18i20 x 2, Novation ReMote 25SL
Posts: 1997
Joined: Thu Oct 20, 2011 6:09 pm
Location: Comfy chair, UK

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby Strauzzi » Thu Aug 06, 2020 9:09 am

I'm running into something similar, though I have issues with the Miroslav stand-alone plug-in, as well. I've confirmed that I've installed all Miroslav instruments in their default folder; indeed, ST3 and ST4 find the Miroslav files just fine.

Oddly, no matter what I do, the only instruments that appear in Miroslav are Orchestral Percussion. If it means anything, this also happens to be the last Instrument on the list in my Instruments folder, numerically. Doesn't matter; clicking on any of the percussion instruments immediately receives a 'Failed to load instrument <installation path info, etc>'

It's not that the instruments aren't registered, so I have no idea! Anyone experience anything similar, or have advice?
Posts: 2
Joined: Wed Aug 05, 2020 6:04 am

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby Basileusow » Mon Aug 31, 2020 5:08 am

I recently have been running into this issue as well. When I first downloaded MP CE (2 years ago) I had a lot of issues with it downloading correctly and being able to find and load its sounds despite using its default settings. I finally got it to work but there wasn't any change in what I was doing.

Now, for some reason, I am having troubles again. I tried to open the plugin and it gave me this long error code and wouldn't work at all. No sounds, nothing. I decided to uninstall and install it again thinking that this may resolve the problem. However, now I get DLL errors saying that ".vpa" can't be loaded. I am using IK Product Manager and it is saying the software is being downloaded correctly but obviously there is something wrong.

I'm not sure how to proceed since as far as I can tell the .vpa file is in the correct spot and I don't know why it wouldn't load. I luckily still have the sound content since the 180 days are up but I'm just hoping that I can get some help fixing MP.
Posts: 9
Joined: Mon Jul 30, 2018 5:51 am

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby DarkStar » Mon Aug 31, 2020 10:46 am

As this is primarily a user to user forum, someone-else may chime in [#]. Meanwhile, the best thing to do is check the FAQs, via here. If they do not resolve the issue, there is a link to the Technical Support form, for some one to one investigation and help. Response time is usually within 2 working days (US (East Coast) Business hours, generally), but in the current circumstances please allow some more time.

[#] But please remember that the same symptoms do not necessarily mean the same problem.

And, to help others who run into a similar problem, please let us know what you did to resolve the problem.
DarkStar ... interesting, if true.
Inspired by ...
User avatar
Hero Of The Week (Moderator)
Posts: 7112
Joined: Fri Dec 17, 2010 5:42 pm
Location: Surrey, UK

Re: All Sorts of Problems with Miroslav Philharmonik 2

Postby Traktorr » Fri Oct 30, 2020 1:14 am

I've found a solution for the .dll error and ".vpa can't be loaded" error. I uninstalled MP2 and then just installed the previous versions first (2.0.1, then 2.0.2 over it, and so on). Finally, the latest (2.0.6) version worked without errors.

Maybe this helps someone.
Posts: 1
Joined: Sat Oct 24, 2020 8:39 pm

Return to Virtual Instruments: SampleTank, Hammond B-3X, More